What’s Vulnerable › Vulnerabilities
CVE-2024-31851
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-05 · updated 2026-06-17
- Weakness: CWE-22
Description
A path traversal vulnerability exists in the Java version of CData Sync < 23.4.8843 when running using the embedded Jetty server, which could allow an unauthenticated remote attacker to gain access to sensitive information and perform limited actions.
Affected products
- CData Sync: before 23.4.8843 — fixed in 23.4.8843
How to fix
Upgrade to a fixed version: CData Sync 23.4.8843. Check the vendor advisory for mitigations.
References
- https://www.tenable.com/security/research/tra-2024-09
- https://www.tenable.com/security/research/tra-2024-09
Get alerted when CVE-2024-31851 or the next vulnerability affects your stack