What’s Vulnerable › Vulnerabilities
CVE-2024-31860: Apache Zeppelin: Path traversal vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.9.0 before 0.11.0 — fixed in 0.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/zeppelin/pull/4632
- https://lists.apache.org/thread/c0zfjnow3oc3dzc8w5rbkzj8lqj5jm5x
- http://www.openwall.com/lists/oss-security/2024/04/09/2
- https://github.com/apache/zeppelin/pull/4632
- https://lists.apache.org/thread/c0zfjnow3oc3dzc8w5rbkzj8lqj5jm5x
Get alerted when CVE-2024-31860 or the next vulnerability affects your stack