What’s Vulnerable › Vulnerabilities
CVE-2024-31862: Apache Zeppelin: Denial of service with invalid notebook name
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.10.1 before 0.11.0 — fixed in 0.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/09/5
- https://github.com/apache/zeppelin/pull/4632
- https://lists.apache.org/thread/73xdjx43yg4yz8bd4p3o8vzyybkysmn0
- http://www.openwall.com/lists/oss-security/2024/04/09/5
- https://github.com/apache/zeppelin/pull/4632
- https://lists.apache.org/thread/73xdjx43yg4yz8bd4p3o8vzyybkysmn0
Get alerted when CVE-2024-31862 or the next vulnerability affects your stack