What’s Vulnerable › Vulnerabilities
CVE-2024-31864: Apache Zeppelin: Remote code execution by adding malicious JDBC connection string
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Zeppelin. The attacker can inject sensitive configuration or malicious code when connecting MySQL database via JDBC driver. This issue affects Apache Zeppelin: before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/09/8
- https://github.com/apache/zeppelin/pull/4709
- https://lists.apache.org/thread/752qdk0rnkd9nqtornz734zwb7xdwcdb
- https://www.cve.org/CVERecord?id=CVE-2020-11974
- http://www.openwall.com/lists/oss-security/2024/04/09/8
- http://www.openwall.com/lists/oss-security/2025/08/03/3
- https://github.com/apache/zeppelin/pull/4709
- https://lists.apache.org/thread/752qdk0rnkd9nqtornz734zwb7xdwcdb
- https://www.cve.org/CVERecord?id=CVE-2020-11974
Get alerted when CVE-2024-31864 or the next vulnerability affects your stack