What’s Vulnerable › Vulnerabilities
CVE-2024-31865: Apache Zeppelin: Cron arbitrary user impersonation with improper privileges
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Zeppelin. The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.8.2 before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/09/9
- https://github.com/apache/zeppelin/pull/4631
- https://lists.apache.org/thread/slm1sf0slwc11f4m4r0nd6ot2rf7w81l
- http://www.openwall.com/lists/oss-security/2024/04/09/9
- https://github.com/apache/zeppelin/pull/4631
- https://lists.apache.org/thread/slm1sf0slwc11f4m4r0nd6ot2rf7w81l
Get alerted when CVE-2024-31865 or the next vulnerability affects your stack