What’s Vulnerable › Vulnerabilities
CVE-2024-31866: Apache Zeppelin: Interpreter download command does not escape malicious code injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-116
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.8.2 before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/09/10
- https://github.com/apache/zeppelin/pull/4715
- https://lists.apache.org/thread/jpkbq3oktopt34x2n5wnhzc2r1410ddd
- http://www.openwall.com/lists/oss-security/2024/04/09/10
- https://github.com/apache/zeppelin/pull/4715
- https://lists.apache.org/thread/jpkbq3oktopt34x2n5wnhzc2r1410ddd
Get alerted when CVE-2024-31866 or the next vulnerability affects your stack