What’s Vulnerable › Vulnerabilities
CVE-2024-31867: Apache Zeppelin: LDAP search filter query Injection Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Zeppelin. The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.8.2 before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/09/12
- https://github.com/apache/zeppelin/pull/4714
- https://lists.apache.org/thread/s4scw8bxdhrjs0kg0lhb68xqd8y9lrtf
- http://www.openwall.com/lists/oss-security/2024/04/09/12
- https://github.com/apache/zeppelin/pull/4714
- https://lists.apache.org/thread/s4scw8bxdhrjs0kg0lhb68xqd8y9lrtf
Get alerted when CVE-2024-31867 or the next vulnerability affects your stack