What’s Vulnerable › Vulnerabilities
CVE-2024-31868: Apache Zeppelin: XSS vulnerability in the helium module
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can modify helium.json and exposure XSS attacks to normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: from 0.8.2 before 0.11.1 — fixed in 0.11.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/apache/zeppelin/pull/4728
- https://lists.apache.org/thread/55mqs673plsxmgnq7fdf2flftpllyf11
- http://www.openwall.com/lists/oss-security/2024/04/09/11
- https://github.com/apache/zeppelin/pull/4728
- https://lists.apache.org/thread/55mqs673plsxmgnq7fdf2flftpllyf11
Get alerted when CVE-2024-31868 or the next vulnerability affects your stack