What’s Vulnerable › Vulnerabilities
CVE-2024-31869: Apache Airflow: Sensitive configuration for providers displayed when "non-sensitive-only" config used
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-200
Description
Airflow versions 2.7.0 through 2.8.4 have a vulnerability that allows an authenticated user to see sensitive provider configuration via the "configuration" UI page when "non-sensitive-only" was set as "webserver.expose_config" configuration (The celery provider is the only community provider currently that has sensitive configurations). You should migrate to Airflow 2.9 or change your "expose_config" configuration to False as a workaround. This is similar, but different to CVE-2023-46288 https://github.com/advisories/GHSA-9qqg-mh7c-chfq which concerned API, not UI configuration page.
Affected products
- Apache Airflow: from 2.7.0 before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.9.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/04/17/10
- https://github.com/apache/airflow/pull/38795
- https://lists.apache.org/thread/pz6vg7wcjk901rmsgt86h76g6kfcgtk3
- http://www.openwall.com/lists/oss-security/2024/04/17/10
- https://github.com/apache/airflow/pull/38795
- https://lists.apache.org/thread/pz6vg7wcjk901rmsgt86h76g6kfcgtk3
Get alerted when CVE-2024-31869 or the next vulnerability affects your stack