What’s Vulnerable › Vulnerabilities
CVE-2024-31936: WordPress UsersWP plugin < 1.2.6 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in AyeCode Ltd UsersWP.This issue affects UsersWP: from n/a before 1.2.6.
Affected products
- stiofansisland UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: stiofansisland UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP 1.2.6. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/userswp/wordpress-userswp-front-end-login-form-user-registration-user-profile-members-directory-plugin-for-wordpress-plugin-1-2-6-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/userswp/wordpress-userswp-front-end-login-form-user-registration-user-profile-members-directory-plugin-for-wordpress-plugin-1-2-6-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-31936 or the next vulnerability affects your stack