What’s Vulnerable › Vulnerabilities
CVE-2024-31979: Apache StreamPipes: Possibility of SSRF in pipeline element installation process
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements. Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address. This issue affects Apache StreamPipes: through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache StreamPipes: before 0.95.0 — fixed in 0.95.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache StreamPipes 0.95.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/8lryp3bxnby9kmk13odkz2jbfdjfvf0y
- http://www.openwall.com/lists/oss-security/2024/07/16/11
- https://lists.apache.org/thread/8lryp3bxnby9kmk13odkz2jbfdjfvf0y
Get alerted when CVE-2024-31979 or the next vulnerability affects your stack