What’s Vulnerable › Vulnerabilities

CVE-2024-32004: Git vulnerable to Remote Code Execution while cloning special-crafted local repositories

Description

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.

Affected products

How to fix

Upgrade to a fixed version: git 2.39.4, 2.40.2, 2.42.2, 2.43.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-32004 or the next vulnerability affects your stack