What’s Vulnerable › Vulnerabilities
CVE-2024-32022: Kohya_ss is vulnerable to a command injection in basic_caption_gui.py (GHSL-2024-019)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-77
Description
Kohya_ss is a GUI for Kohya's Stable Diffusion trainers. Kohya_ss is vulnerable to command injection in basic_caption_gui.py. This vulnerability is fixed in 23.1.5.
Affected products
- bmaltais kohya_ss: from 22.6.1 before 23.1.15 — fixed in 23.1.15
How to fix
Upgrade to a fixed version: bmaltais kohya_ss 23.1.15. Check the vendor advisory for mitigations.
References
- https://github.com/bmaltais/kohya_ss/commit/831af8babeb75faff62bcc6a8c6a4f80354f1ff1
- https://github.com/bmaltais/kohya_ss/security/advisories/GHSA-m6jq-7j4v-2fg3
- https://securitylab.github.com/advisories/GHSL-2024-019_GHSL-2024-024_kohya_ss
- https://github.com/bmaltais/kohya_ss/commit/831af8babeb75faff62bcc6a8c6a4f80354f1ff1
- https://github.com/bmaltais/kohya_ss/security/advisories/GHSA-m6jq-7j4v-2fg3
- https://securitylab.github.com/advisories/GHSL-2024-019_GHSL-2024-024_kohya_ss
Get alerted when CVE-2024-32022 or the next vulnerability affects your stack