What’s Vulnerable › Vulnerabilities
CVE-2024-32023: Kohya_ss vulnerable to path injection in `common_gui.py` `find_and_replace` function (`GHSL-2024-024`)
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-22
Description
Kohya_ss is a GUI for Kohya's Stable Diffusion trainers. Kohya_ss is vulnerable to a path injection in the `common_gui.py` `find_and_replace` function. This vulnerability is fixed in 23.1.5.
Affected products
- bmaltais kohya_ss: from 22.6.1 before 24.0.1 — fixed in 24.0.1
How to fix
Upgrade to a fixed version: bmaltais kohya_ss 24.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/bmaltais/kohya_ss/commit/8bc67a7467f8366db1a4b9b3b14525ec763f1650
- https://github.com/bmaltais/kohya_ss/security/advisories/GHSA-p945-7qm7-7j53
- https://securitylab.github.com/advisories/GHSL-2024-019_GHSL-2024-024_kohya_ss
- https://github.com/bmaltais/kohya_ss/commit/8bc67a7467f8366db1a4b9b3b14525ec763f1650
- https://github.com/bmaltais/kohya_ss/security/advisories/GHSA-p945-7qm7-7j53
- https://securitylab.github.com/advisories/GHSL-2024-019_GHSL-2024-024_kohya_ss
Get alerted when CVE-2024-32023 or the next vulnerability affects your stack