What’s Vulnerable › Vulnerabilities
CVE-2024-3203: c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-122
Description
A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.
Affected products
- c-blosc2: through 2.13.2
References
- https://drive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharing
- https://github.com/Blosc/c-blosc2/releases/tag/v2.14.3
- https://vuldb.com/?ctiid.259050
- https://vuldb.com/?id.259050
- https://vuldb.com/?submit.304556
- https://drive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharing
- https://github.com/Blosc/c-blosc2/releases/tag/v2.14.3
- https://vuldb.com/?ctiid.259050
- https://vuldb.com/?id.259050
- https://vuldb.com/?submit.304556
Get alerted when CVE-2024-3203 or the next vulnerability affects your stack