What’s Vulnerable › Vulnerabilities
CVE-2024-32034: Cross-site scripting (XSS) in the decidim admin activity log
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-16 · updated 2026-06-17
- Weakness: CWE-79
Description
decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The admin panel is subject to potential Cross-site scripting (XSS) attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. This issue has been addressed in release version 0.27.7, 0.28.2, and newer. Users are advised to upgrade. Users unable to upgrade may redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. `/admin/organization/edit`).
Affected products
- decidim: before 0.27.7; 0.28.0, 0.28.1 — fixed in 0.27.7
How to fix
Upgrade to a fixed version: decidim 0.27.7. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/commit/23fc8d702a4976727f78617f5e42353d67931645
- https://github.com/decidim/decidim/commit/9d79f09a2d38c87feb28725670d6cc1f55c22072
- https://github.com/decidim/decidim/commit/e494235d559be13dd1f8694345e6f6bba762d1c0
- https://github.com/decidim/decidim/commit/ff755e23814aeb56e9089fc08006a5d3faee47b6
- https://github.com/decidim/decidim/security/advisories/GHSA-rx9f-5ggv-5rh6
Get alerted when CVE-2024-32034 or the next vulnerability affects your stack