What’s Vulnerable › Vulnerabilities
CVE-2024-32036: SixLabors.ImageSharp vulnerable to data leakage
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-226
Description
ImageSharp is a 2D graphics API. A data leakage flaw was found in ImageSharp's JPEG and TGA decoders. This vulnerability is triggered when an attacker passes a specially crafted JPEG or TGA image file to a software using ImageSharp, potentially disclosing sensitive information from other parts of the software in the resulting image buffer. The problem has been patched in v3.1.4 and v2.1.8.
Affected products
- SixLabors ImageSharp: before 2.1.8; from 3.0.0 before 3.1.4 — fixed in 2.1.8, 3.1.4
How to fix
Upgrade to a fixed version: SixLabors ImageSharp 2.1.8, 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/SixLabors/ImageSharp/commit/8f0b4d3e680e78d479a88e7b1472bccd8f096d68
- https://github.com/SixLabors/ImageSharp/commit/da5f09a42513489fe359578d81cec2f15ba588ba
- https://github.com/SixLabors/ImageSharp/security/advisories/GHSA-5x7m-6737-26cr
- https://github.com/SixLabors/ImageSharp/commit/8f0b4d3e680e78d479a88e7b1472bccd8f096d68
- https://github.com/SixLabors/ImageSharp/commit/da5f09a42513489fe359578d81cec2f15ba588ba
- https://github.com/SixLabors/ImageSharp/security/advisories/GHSA-5x7m-6737-26cr
Get alerted when CVE-2024-32036 or the next vulnerability affects your stack