What’s Vulnerable › Vulnerabilities
CVE-2024-32037: GeoNetwork vulnerable to search end-point information disclosure in response headers
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-200
Description
GeoNetwork is a catalog application to manage spatially referenced resources. In versions prior to 4.2.10 and 4.4.5, the search end-point response headers contain information about Elasticsearch software in use. This information is valuable from a security point of view because it allows software used by the server to be easily identified. GeoNetwork 4.4.5 and 4.2.10 fix this issue. No known workarounds are available.
Affected products
- geonetwork core-geonetwork: before 4.2.10; from 4.4.0 before 4.4.5 — fixed in 4.2.10, 4.4.5
How to fix
Upgrade to a fixed version: geonetwork core-geonetwork 4.2.10, 4.4.5. Check the vendor advisory for mitigations.
References
- https://docs.geonetwork-opensource.org/4.4/api/search
- https://github.com/geonetwork/core-geonetwork/releases/tag/4.2.10
- https://github.com/geonetwork/core-geonetwork/releases/tag/4.4.5
- https://github.com/geonetwork/core-geonetwork/security/advisories/GHSA-52rf-25hq-5m33
Get alerted when CVE-2024-32037 or the next vulnerability affects your stack