What’s Vulnerable › Vulnerabilities
CVE-2024-3204: c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-122
Description
A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.
Affected products
- c-blosc2: through 2.13.2
References
- https://drive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharing
- https://github.com/Blosc/c-blosc2/releases/tag/v2.14.3
- https://vuldb.com/?ctiid.259051
- https://vuldb.com/?id.259051
- https://vuldb.com/?submit.304557
- https://drive.google.com/drive/folders/1T1k3UeS09m65LjVXExUuZfedNQPWQWCo?usp=sharing
- https://github.com/Blosc/c-blosc2/releases/tag/v2.14.3
- https://vuldb.com/?ctiid.259051
- https://vuldb.com/?id.259051
- https://vuldb.com/?submit.304557
Get alerted when CVE-2024-3204 or the next vulnerability affects your stack