What’s Vulnerable › Vulnerabilities
CVE-2024-32106: WordPress WP Compress plugin <= 6.10.35 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-11 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in WP Compress WP Compress – Image Optimizer [All-In-One].This issue affects WP Compress – Image Optimizer [All-In-One]: from n/a through 6.10.35.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.11.01 — fixed in 6.11.01
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.11.01. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-compress-image-optimizer/wordpress-wp-compress-plugin-6-10-35-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-compress-image-optimizer/wordpress-wp-compress-plugin-6-10-35-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-32106 or the next vulnerability affects your stack