What’s Vulnerable › Vulnerabilities
CVE-2024-32114: Apache ActiveMQ: Jolokia and REST API were not secured with default configuration
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-1188
Description
In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST API are located). It means that anyone can use these layers without any required authentication. Potentially, anyone can interact with the broker (using Jolokia JMX REST API) and/or produce/consume messages or purge/delete destinations (using the Message REST API). To mitigate, users can update the default conf/jetty.xml configuration file to add authentication requirement: <bean id="securityConstraintMapping" class="org.eclipse.jetty.security.ConstraintMapping"> <property name="constraint" ref="securityConstraint" /> <property name="pathSpec" value="/" /> </bean> Or we encourage users to upgrade to Apache ActiveMQ 6.1.2 where the default configuration has been updated with authentication by default.
Affected products
- Apache ActiveMQ: from 6.0.0 before 6.1.2 — fixed in 6.1.2
How to fix
Upgrade to a fixed version: Apache ActiveMQ 6.1.2. Check the vendor advisory for mitigations.
References
- https://activemq.apache.org/security-advisories.data/CVE-2024-32114-announcement.txt
- https://activemq.apache.org/security-advisories.data/CVE-2024-32114-announcement.txt
Get alerted when CVE-2024-32114 or the next vulnerability affects your stack