What’s Vulnerable › Vulnerabilities

CVE-2024-32123

Description

Multiple improper neutralization of special elements used in an os command ('os command injection') in Fortinet FortiManager, FortiAnalyzer versions 7.4.0 through 7.4.2 7.2.0 through 7.2.5 and 7.0.0 through 7.0.12 and 6.4.0 through 6.4.14 and 6.2.0 through 6.2.12 and 6.0.0 through 6.0.12 and 5.6.0 through 5.6.11 and 5.4.0 through 5.4.7 and 5.2.0 through 5.2.10 and 5.0.0 through 5.0.12 and 4.3.4 through 4.3.8 allows attacker to execute unauthorized code or commands via crafted CLI requests.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiAnalyzer 7.2.6, 7.4.4; Fortinet Fortianalyzer Big Data 7.2.8, 7.4.2; Fortinet FortiManager 7.2.6, 7.4.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-32123 or the next vulnerability affects your stack