What’s Vulnerable › Vulnerabilities
CVE-2024-32125: WordPress BA Book Everything plugin <= 1.6.4 - Auth. SQL Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Booking Algorithms BA Book Everything.This issue affects BA Book Everything: from n/a through 1.6.4.
Affected products
- bookingalgorithms BA Book Everything: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: bookingalgorithms BA Book Everything 1.6.5. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/ba-book-everything/wordpress-ba-book-everything-plugin-1-6-4-sql-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/ba-book-everything/wordpress-ba-book-everything-plugin-1-6-4-sql-injection-vulnerability?_s_id=cve
Get alerted when CVE-2024-32125 or the next vulnerability affects your stack