What’s Vulnerable › Vulnerabilities
CVE-2024-3213: Relevanssi – A Better Search <= 4.22.1 - Missing Authorization to Unauthenticated Count Option Update
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-862
Description
The Relevanssi – A Better Search plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the relevanssi_update_counts() function in all versions up to, and including, 4.22.1. This makes it possible for unauthenticated attackers to execute expensive queries on the application that could lead into DOS.
Affected products
- Relevanssi: before 4.22.2 — fixed in 4.22.2
How to fix
Upgrade to a fixed version: Relevanssi 4.22.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/relevanssi/trunk/lib/admin-ajax.php#L443
- https://plugins.trac.wordpress.org/changeset/3064304/relevanssi/tags/4.22.2/lib/admin-ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e625130f-8e21-4baf-9d3c-4cbb806b9e52?source=cve
- https://plugins.trac.wordpress.org/browser/relevanssi/trunk/lib/admin-ajax.php#L443
- https://plugins.trac.wordpress.org/changeset/3064304/relevanssi/tags/4.22.2/lib/admin-ajax.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e625130f-8e21-4baf-9d3c-4cbb806b9e52?source=cve
Get alerted when CVE-2024-3213 or the next vulnerability affects your stack