What’s Vulnerable › Vulnerabilities
CVE-2024-32145: WordPress WP Google Analytics Events – No-Code Custom Event Tracking for Google Analytics plugin <= 2.8.0 - Reflected Cross-Site Scripting vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PineWise WP Google Analytics Events allows Reflected XSS.This issue affects WP Google Analytics Events: from n/a through 2.8.0.
Affected products
- PineWise WP Google Analytics Events: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: PineWise WP Google Analytics Events 2.8.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-google-analytics-events/wordpress-wp-google-analytics-events-no-code-custom-event-tracking-for-google-analytics-plugin-2-8-0-reflected-cross-site-scripting-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-google-analytics-events/wordpress-wp-google-analytics-events-no-code-custom-event-tracking-for-google-analytics-plugin-2-8-0-reflected-cross-site-scripting-vulnerability?_s_id=cve
Get alerted when CVE-2024-32145 or the next vulnerability affects your stack