What’s Vulnerable › Vulnerabilities
CVE-2024-3215: Paid Memberships Pro <= 3.0.1 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-352
Description
The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1. This is due to missing or incorrect nonce validation on the pmpro_update_level_group_order() function. This makes it possible for unauthenticated attackers to update order levels via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Paid Memberships Pro: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: Paid Memberships Pro 3.0.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3069136/paid-memberships-pro/trunk/includes/services.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a9ef7742-e6f8-4350-90e9-242d9d1b12a0?source=cve
- https://plugins.trac.wordpress.org/changeset/3069136/paid-memberships-pro/trunk/includes/services.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a9ef7742-e6f8-4350-90e9-242d9d1b12a0?source=cve
Get alerted when CVE-2024-3215 or the next vulnerability affects your stack