What’s Vulnerable › Vulnerabilities
CVE-2024-3239: PostX < 4.0.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Grid Gutenberg Blocks and WordPress Blog Plugin WordPress plugin before 4.0.2 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- WPXPO PostX: before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: WPXPO PostX 4.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dfa1421b-41b0-4b25-95ef-0843103e1f5e/
- https://wpscan.com/vulnerability/dfa1421b-41b0-4b25-95ef-0843103e1f5e/
Get alerted when CVE-2024-3239 or the next vulnerability affects your stack