What’s Vulnerable › Vulnerabilities
CVE-2024-3241: Ultimate Blocks < 3.1.7 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultimate Blocks WordPress plugin before 3.1.7 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor: before 3.1.7 — fixed in 3.1.7
How to fix
Upgrade to a fixed version: ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block Editor 3.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a645daee-42ea-43f8-9480-ef3be69606e0/
- https://wpscan.com/vulnerability/a645daee-42ea-43f8-9480-ef3be69606e0/
Get alerted when CVE-2024-3241 or the next vulnerability affects your stack