What’s Vulnerable › Vulnerabilities
CVE-2024-3242: Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-434
Description
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file extension validation in the validateImageContent function called via storeImages in all versions up to, and including, 2.4.43. This makes it possible for authenticated attackers, with contributor access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. Version 2.4.44 prevents the upload of files ending in .sh and .php. Version 2.4.45 fully patches the issue.
Affected products
- themefusecom Brizy – Page Builder: before 2.4.45 — fixed in 2.4.45
How to fix
Upgrade to a fixed version: themefusecom Brizy – Page Builder 2.4.45. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L264
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L547
- https://plugins.trac.wordpress.org/changeset/3086506/brizy/trunk/editor/zip/archiver.php
- https://plugins.trac.wordpress.org/changeset/3112878/brizy/trunk?contextall=1&old=3086506&old_path=%2Fbrizy%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a414de0a-ae44-4955-bd25-ec6ad7860835?source=cve
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L264
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L547
- https://plugins.trac.wordpress.org/changeset/3086506/brizy/trunk/editor/zip/archiver.php
- https://plugins.trac.wordpress.org/changeset/3112878/brizy/trunk?contextall=1&old=3086506&old_path=%2Fbrizy%2Ftrunk
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a414de0a-ae44-4955-bd25-ec6ad7860835?source=cve
Get alerted when CVE-2024-3242 or the next vulnerability affects your stack