What’s Vulnerable › Vulnerabilities
CVE-2024-32461: LibreNMS vulnerable to time-based SQL injection that leads to database extraction
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-22 · updated 2026-06-17
- Weakness: CWE-89
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A SQL injection vulnerability in POST /search/search=packages in LibreNMS prior to version 24.4.0 allows a user with global read privileges to execute SQL commands via the package parameter. With this vulnerability, an attacker can exploit a SQL injection time based vulnerability to extract all data from the database, such as administrator credentials. Version 24.4.0 contains a patch for the vulnerability.
Affected products
- librenms: before 24.4.0 — fixed in 24.4.0
How to fix
Upgrade to a fixed version: librenms 24.4.0. Check the vendor advisory for mitigations.
References
- https://doc.clickup.com/9013166444/p/h/8ckm0bc-53/16811991bb5fff6
- https://github.com/librenms/librenms/commit/d29201fce134347f891102699fbde7070debee33
- https://github.com/librenms/librenms/security/advisories/GHSA-cwx6-cx7x-4q34
- https://doc.clickup.com/9013166444/p/h/8ckm0bc-53/16811991bb5fff6
- https://github.com/librenms/librenms/commit/d29201fce134347f891102699fbde7070debee33
- https://github.com/librenms/librenms/security/advisories/GHSA-cwx6-cx7x-4q34
Get alerted when CVE-2024-32461 or the next vulnerability affects your stack