What’s Vulnerable › Vulnerabilities
CVE-2024-32466: Tolgee's API key scopes not checked when querying translation data
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-862
Description
Tolgee is an open-source localization platform. For the `/v2/projects/translations` and `/v2/projects/{projectId}/translations` endpoints, translation data was returned even when API key was missing `translation.view` scope. However, it was impossible to fetch the data when user was missing this scope. So this is only relevant for API keys generated by users permitted to `translation.view`. This vulnerability is fixed in v3.57.2
Affected products
- tolgee-platform: before 3.57.2 — fixed in 3.57.2
How to fix
Upgrade to a fixed version: tolgee-platform 3.57.2. Check the vendor advisory for mitigations.
References
- https://github.com/tolgee/tolgee-platform/commit/f71213925d6f80019f841db0ead9baa7488c1821
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-r95p-fqqv-fppc
- https://github.com/tolgee/tolgee-platform/commit/f71213925d6f80019f841db0ead9baa7488c1821
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-r95p-fqqv-fppc
Get alerted when CVE-2024-32466 or the next vulnerability affects your stack