What’s Vulnerable › Vulnerabilities
CVE-2024-32469: Decidim has cross-site scripting (XSS) in the pagination
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Decidim is a participatory democracy framework. The pagination feature used in searches and filters is subject to potential XSS attack through a malformed URL using the GET parameter `per_page`. This vulnerability is fixed in 0.27.6 and 0.28.1.
Affected products
- decidim: before 0.27.6; from 0.28.0.rc1, < 0.28.1
References
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/releases/tag/v0.28.1
- https://github.com/decidim/decidim/security/advisories/GHSA-7cx8-44pc-xv3q
- https://github.com/decidim/decidim/releases/tag/v0.27.6
- https://github.com/decidim/decidim/releases/tag/v0.28.1
- https://github.com/decidim/decidim/security/advisories/GHSA-7cx8-44pc-xv3q
Get alerted when CVE-2024-32469 or the next vulnerability affects your stack