What’s Vulnerable › Vulnerabilities
CVE-2024-32470: Tolgee' API keys created by server admin users bypass the permission check
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-863
Description
Tolgee is an open-source localization platform. When API key created by admin user is used it bypasses the permission check at all. This error was introduced in v3.57.2 and immediately fixed in v3.57.4.
Affected products
- tolgee-platform: from 3.57.2 before 3.57.4 — fixed in 3.57.4
How to fix
Upgrade to a fixed version: tolgee-platform 3.57.4. Check the vendor advisory for mitigations.
References
- https://github.com/tolgee/tolgee-platform/commit/a0d861028d931f8a54387770eaf3a75031b81234
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-pm57-hcm8-38gw
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-r95p-fqqv-fppc
- https://github.com/tolgee/tolgee-platform/commit/a0d861028d931f8a54387770eaf3a75031b81234
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-pm57-hcm8-38gw
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-r95p-fqqv-fppc
Get alerted when CVE-2024-32470 or the next vulnerability affects your stack