What’s Vulnerable › Vulnerabilities
CVE-2024-32474: Sentry's superuser cleartext password leaked in logs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-117
Description
Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.
Affected products
- getsentry sentry: from 24.3.0 before 24.4.1 — fixed in 24.4.1
How to fix
Upgrade to a fixed version: getsentry sentry 24.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/sentry/commit/d5b34568d9f1c41362ccb62141532a0a2169512f
- https://github.com/getsentry/sentry/pull/66393
- https://github.com/getsentry/sentry/pull/69148
- https://github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9
- https://github.com/getsentry/sentry/commit/d5b34568d9f1c41362ccb62141532a0a2169512f
- https://github.com/getsentry/sentry/pull/66393
- https://github.com/getsentry/sentry/pull/69148
- https://github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9
Get alerted when CVE-2024-32474 or the next vulnerability affects your stack