What’s Vulnerable › Vulnerabilities
CVE-2024-32475: Envoy RELEASE_ASSERT using auto_sni with :authority header > 255 bytes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-253
Description
Envoy is a cloud-native, open source edge and service proxy. When an upstream TLS cluster is used with `auto_sni` enabled, a request containing a `host`/`:authority` header longer than 255 characters triggers an abnormal termination of Envoy process. Envoy does not gracefully handle an error when setting SNI for outbound TLS connection. The error can occur when Envoy attempts to use the `host`/`:authority` header value longer than 255 characters as SNI for outbound TLS connection. SNI length is limited to 255 characters per the standard. Envoy always expects this operation to succeed and abnormally aborts the process when it fails. This vulnerability is fixed in 1.30.1, 1.29.4, 1.28.3, and 1.27.5.
Affected products
- envoyproxy envoy: from 1.13.0 before 1.27.5; from 1.28.0 before 1.28.3; from 1.29.0 before 1.29.4; 1.30.0 — fixed in 1.27.5, 1.28.3, 1.29.4
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.27.5, 1.28.3, 1.29.4. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/commit/b47fc6648d7c2dfe0093a601d44cb704b7bad382
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-3mh5-6q8v-25wj
- https://github.com/envoyproxy/envoy/commit/b47fc6648d7c2dfe0093a601d44cb704b7bad382
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-3mh5-6q8v-25wj
Get alerted when CVE-2024-32475 or the next vulnerability affects your stack