What’s Vulnerable › Vulnerabilities
CVE-2024-32479: LibreNMS's Improper Sanitization on Service template name leads to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 34.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to version 24.4.0, there is improper sanitization on the `Service` template name, which can lead to stored Cross-site Scripting. Version 24.4.0 fixes this vulnerability.
Affected products
- librenms: before 24.4.0 — fixed in 24.4.0
How to fix
Upgrade to a fixed version: librenms 24.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/blob/a61c11db7e8ef6a437ab55741658be2be7d14d34/app/Http/Controllers/ServiceTemplateController.php#L67C23-L67C23
- https://github.com/librenms/librenms/commit/19344f0584d4d6d4526fdf331adc60530e3f685b
- https://github.com/librenms/librenms/security/advisories/GHSA-72m9-7c8x-pmmw
- https://github.com/librenms/librenms/blob/a61c11db7e8ef6a437ab55741658be2be7d14d34/app/Http/Controllers/ServiceTemplateController.php#L67C23-L67C23
- https://github.com/librenms/librenms/commit/19344f0584d4d6d4526fdf331adc60530e3f685b
- https://github.com/librenms/librenms/security/advisories/GHSA-72m9-7c8x-pmmw
Get alerted when CVE-2024-32479 or the next vulnerability affects your stack