What’s Vulnerable › Vulnerabilities
CVE-2024-32480: LibreNMS's Time-Based Blind SQL injection leads to database extraction
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 20.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-22 · updated 2026-06-17
- Weakness: CWE-89
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Versions prior to 24.4.0 are vulnerable to SQL injection. The `order` parameter is obtained from `$request`. After performing a string check, the value is directly incorporated into an SQL statement and concatenated, resulting in a SQL injection vulnerability. An attacker may extract a whole database this way. Version 24.4.0 fixes the issue.
Affected products
- librenms: before 24.4.0 — fixed in 24.4.0
How to fix
Upgrade to a fixed version: librenms 24.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/83fe4b10c440d69a47fe2f8616e290ba2bd3a27c
- https://github.com/librenms/librenms/security/advisories/GHSA-jh57-j3vq-h438
- https://github.com/librenms/librenms/commit/83fe4b10c440d69a47fe2f8616e290ba2bd3a27c
- https://github.com/librenms/librenms/security/advisories/GHSA-jh57-j3vq-h438
Get alerted when CVE-2024-32480 or the next vulnerability affects your stack