What’s Vulnerable › Vulnerabilities
CVE-2024-32488
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-15 · updated 2026-06-17
- Weakness: CWE-280
Description
In Foxit PDF Reader and Editor before 2024.1, Local Privilege Escalation could occur during update checks because weak permissions on the update-service folder allow attackers to place crafted DLL files there.
Affected products
- Foxit PDF Reader: before 10.1.12.37872; from 11.0.0 before 11.2.8.53842; from 12.0.0 before 12.1.4.15400; from 13.0.0 before 13.0.1.21693; from 2023.1.0.15510 before 2023.3.0.23028 — fixed in 10.1.12.37872, 11.2.8.53842, 12.1.4.15400, 13.0.1.21693, 2023.3.0.23028
- Foxit Pdf Reader: before 2023.3.0.23028 — fixed in 2023.3.0.23028
How to fix
Upgrade to a fixed version: Foxit PDF Reader 10.1.12.37872, 11.2.8.53842, 12.1.4.15400, 13.0.1.21693; Foxit Pdf Reader 2023.3.0.23028. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.foxit.com/support/security-bulletins.html
Get alerted when CVE-2024-32488 or the next vulnerability affects your stack