What’s Vulnerable › Vulnerabilities
CVE-2024-3249: Zita Elementor Site Library <= 1.6.2 - Missing Authorization to Page Creation and Options Modification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-862
Description
The Zita Elementor Site Library plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the import_xml_data, xml_data_import, import_option_data, import_widgets, and import_customizer_settings functions in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to create pages, update certain options, including WooCommerce page titles and Elementor settings, import widgets, and update the plugin's customizer settings and the WordPress custom CSS. NOTE: This vulnerability was partially fixed in version 1.6.2.
Affected products
- wpzita Zita Site Library for Elementor: through 1.6.2
References
- https://plugins.trac.wordpress.org/changeset/3100431/zita-site-library
- https://plugins.trac.wordpress.org/changeset/3105478/zita-site-library
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62bc3794-a2c2-4c1a-b1c9-2be6e2526635?source=cve
- https://plugins.trac.wordpress.org/changeset/3100431/zita-site-library
- https://plugins.trac.wordpress.org/changeset/3105478/zita-site-library
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62bc3794-a2c2-4c1a-b1c9-2be6e2526635?source=cve
Get alerted when CVE-2024-3249 or the next vulnerability affects your stack