What’s Vulnerable › Vulnerabilities
CVE-2024-32508: WordPress DethemeKit For Elementor plugin <= 2.0.2 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in deTheme DethemeKit For Elementor allows Stored XSS.This issue affects DethemeKit For Elementor: from n/a through 2.0.2.
Affected products
- DethemeKit For Elementor: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: DethemeKit For Elementor 2.1.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/dethemekit-for-elementor/wordpress-dethemekit-for-elementor-plugin-2-0-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/dethemekit-for-elementor/wordpress-dethemekit-for-elementor-plugin-2-0-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-32508 or the next vulnerability affects your stack