What’s Vulnerable › Vulnerabilities
CVE-2024-32575: WordPress Mega Elements plugin <= 1.1.9 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kraftplugins Mega Elements allows Stored XSS.This issue affects Mega Elements: from n/a through 1.1.9.
Affected products
- Kraft Plugins Mega Elements: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: Kraft Plugins Mega Elements 1.2.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/mega-elements-addons-for-elementor/wordpress-mega-elements-plugin-1-1-9-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/mega-elements-addons-for-elementor/wordpress-mega-elements-plugin-1-1-9-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-32575 or the next vulnerability affects your stack