What’s Vulnerable › Vulnerabilities
CVE-2024-32584: WordPress TeraWallet plugin <= 1.5.0 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in StandaloneTech TeraWallet – For WooCommerce allows Stored XSS.This issue affects TeraWallet – For WooCommerce: from n/a through 1.5.0.
Affected products
- StandaloneTech TeraWallet – For WooCommerce: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: StandaloneTech TeraWallet – For WooCommerce 1.5.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woo-wallet/wordpress-terawallet-plugin-1-5-0-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woo-wallet/wordpress-terawallet-plugin-1-5-0-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-32584 or the next vulnerability affects your stack