What’s Vulnerable › Vulnerabilities
CVE-2024-32595: WordPress WP Helper Premium plugin < 4.6.0 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mat Bao Corp WP Helper Premium allows Reflected XSS.This issue affects WP Helper Premium: from n/a before 4.6.0.
Affected products
- Mat Bao Corp WP Helper Premium: before 4.6.0 — fixed in 4.6.0
How to fix
Upgrade to a fixed version: Mat Bao Corp WP Helper Premium 4.6.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-helper-lite/wordpress-wp-helper-premium-plugin-4-6-0-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-helper-lite/wordpress-wp-helper-premium-plugin-4-6-0-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-32595 or the next vulnerability affects your stack