What’s Vulnerable › Vulnerabilities
CVE-2024-32597: WordPress WP Smart Import plugin <= 1.0.7 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Xylus Themes WordPress Importer allows Stored XSS.This issue affects WordPress Importer: from n/a through 1.0.7.
Affected products
- Xylus Themes WP Smart Import: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Xylus Themes WP Smart Import 1.1.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-smart-import/wordpress-wp-smart-import-plugin-1-0-7-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wp-smart-import/wordpress-wp-smart-import-plugin-1-0-7-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2024-32597 or the next vulnerability affects your stack