What’s Vulnerable › Vulnerabilities
CVE-2024-32632: Printf arg type mismatch in ATCMD
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-686
Description
A value in ATCMD will be misinterpreted by printf, causing incorrect output and possibly out-of-bounds memory access
Affected products
- Asrmicro Asr1602 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1603 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1605 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1606 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1607 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1609 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1803 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1803Sc Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr1806 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr3602 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr3603 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr3605 Firmware: before cp01.057.067 — fixed in cp01.057.067
- Asrmicro Asr3607 Firmware: before cp01.057.067 — fixed in cp01.057.067
How to fix
Upgrade to a fixed version: Asrmicro Asr1602 Firmware cp01.057.067; Asrmicro Asr1603 Firmware cp01.057.067; Asrmicro Asr1605 Firmware cp01.057.067; Asrmicro Asr1606 Firmware cp01.057.067; Asrmicro Asr1607 Firmware cp01.057.067; Asrmicro Asr1609 Firmware cp01.057.067; Asrmicro Asr1803 Firmware cp01.057.067; Asrmicro Asr1803Sc Firmware cp01.057.067; Asrmicro Asr1806 Firmware cp01.057.067; Asrmicro Asr3602 Firmware cp01.057.067; Asrmicro Asr3603 Firmware cp01.057.067; Asrmicro Asr3605 Firmware cp01.057.067. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-32632 or the next vulnerability affects your stack