What’s Vulnerable › Vulnerabilities
CVE-2024-32638: Apache APISIX: Forward-Auth Request Smuggling
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-444
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: 3.8.0, 3.9.0
References
- http://www.openwall.com/lists/oss-security/2024/05/02/2
- https://lists.apache.org/thread/ngvgxllw4zn4hgngkqw2o225kf9wotov
- http://www.openwall.com/lists/oss-security/2024/05/02/2
- https://lists.apache.org/thread/ngvgxllw4zn4hgngkqw2o225kf9wotov
Get alerted when CVE-2024-32638 or the next vulnerability affects your stack