What’s Vulnerable › Vulnerabilities
CVE-2024-32641: Masa CMS Vulnerable to Pre-Auth RCE via JSON API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-03 · updated 2026-09-26
- Weakness: CWE-94
Description
Masa CMS is an open source Enterprise Content Management platform. Masa CMS versions prior to 7.2.8, 7.3.13, and 7.4.6 are vulnerable to remote code execution. The vulnerability exists in the addParam function, which accepts user input via the criteria parameter. This input is subsequently evaluated by setDynamicContent, allowing an unauthenticated attacker to execute arbitrary code via the m tag. The vulnerability is patched in versions 7.2.8, 7.3.13, and 7.4.6.
Affected products
- MasaCMS: before 7.2.8; from 7.3 before 7.3.13; from 7.4.0 before 7.4.6 — fixed in 7.2.8, 7.3.13, 7.4.6
How to fix
Upgrade to a fixed version: MasaCMS 7.2.8, 7.3.13, 7.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/MasaCMS/MasaCMS/commit/fb27f822fe426496af71205fa35208e58823fcf6
- https://github.com/MasaCMS/MasaCMS/security/advisories/GHSA-cj9g-v5mq-qrjm
Get alerted when CVE-2024-32641 or the next vulnerability affects your stack