What’s Vulnerable › Vulnerabilities
CVE-2024-32653: Insufficient input filtering of "package name" allows command execution in the device with shell privileges
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-22 · updated 2026-06-17
- Weakness: CWE-20
Description
jadx is a Dex to Java decompiler. Prior to version 1.5.0, the package name is not filtered before concatenation. This can be exploited to inject arbitrary code into the package name. The vulnerability allows an attacker to execute commands with shell privileges. Version 1.5.0 contains a patch for the vulnerability.
Affected products
- skylot Jadx: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: skylot Jadx 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/skylot/jadx/blob/9114821fb12558874e01421bf38b0d34fb39df72/jadx-gui/src/main/java/jadx/gui/device/protocol/ADBDevice.java#L108-L109
- https://github.com/skylot/jadx/releases/tag/v1.5.0
- https://github.com/skylot/jadx/security/advisories/GHSA-3pp3-hg2q-9gpm
- https://github.com/skylot/jadx/blob/9114821fb12558874e01421bf38b0d34fb39df72/jadx-gui/src/main/java/jadx/gui/device/protocol/ADBDevice.java#L108-L109
- https://github.com/skylot/jadx/releases/tag/v1.5.0
- https://github.com/skylot/jadx/security/advisories/GHSA-3pp3-hg2q-9gpm
Get alerted when CVE-2024-32653 or the next vulnerability affects your stack