What’s Vulnerable › Vulnerabilities
CVE-2024-3271: Command Injection in run-llama/llama_index
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-16 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability exists in the run-llama/llama_index repository, specifically within the safe_eval function. Attackers can bypass the intended security mechanism, which checks for the presence of underscores in code generated by LLM, to execute arbitrary code. This is achieved by crafting input that does not contain an underscore but still results in the execution of OS commands. The vulnerability allows for remote code execution (RCE) on the server hosting the application.
Affected products
- run-llama/llama_index: from 0.10.6 before 0.10.26 — fixed in 0.10.26
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.10.26. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/5fbcb5a8b9f20f81b791c7fc8849e352613ab475
- https://huntr.com/bounties/9b32490e-7cf9-470e-8d49-ba083ae7a279
- https://github.com/run-llama/llama_index/commit/5fbcb5a8b9f20f81b791c7fc8849e352613ab475
- https://huntr.com/bounties/9b32490e-7cf9-470e-8d49-ba083ae7a279
Get alerted when CVE-2024-3271 or the next vulnerability affects your stack