What’s Vulnerable › Vulnerabilities
CVE-2024-32830: WordPress buddyforms plugin <= 2.8.8- Arbitrary File Read and SSRF vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in ThemeKraft BuddyForms allows Server Side Request Forgery, Relative Path Traversal.This issue affects BuddyForms: from n/a through 2.8.8.
Affected products
- Themekraft BuddyForms: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: Themekraft BuddyForms 2.8.9. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/buddyforms/wordpress-buddyforms-plugin-2-8-8-arbitrary-file-read-and-ssrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/buddyforms/wordpress-buddyforms-plugin-2-8-8-arbitrary-file-read-and-ssrf-vulnerability?_s_id=cve
Get alerted when CVE-2024-32830 or the next vulnerability affects your stack